Jun 1, 2018 - James Ramsay    

Breaking change: Support for API v3 will be removed June 4

With the removal of deprecated GitLab API v3 in GitLab 11.0, requests to the API v3 will fail.

On June 4, 2018 integrations using API v3 connected to GitLab.com will stop working. With the release of GitLab 11 on June 22, 2018 the API v3 will be removed completely. Update all integrations before June 4 to avoid downtime.

In the GitLab 8.17 release post, we announced the deprecation of API v3, and that support for API v3 would be dropped in a future release.

Please ensure that you upgrade any integrations to API v4 to avoid any downtime. Documentation is available for upgrading from v3 to v4.

When will this happen?

The API v3 will be removed in GitLab 11.0 on 22 June, 2018. Please consider that integrations using API v3 connected to GitLab.com will stop working as soon as the first RC is deployed to production, and this will happen around 4 June, 2018. Update all integrations before this date.

Install GitLab in 2 minutes

With Ubuntu, Debian, CentOS, openSUSE, and Raspbian packages or from source

Install GitLab Now

Try GitLab Ultimate risk-free for 30 days.

No credit card required. Have questions? Contact us.