A bug in certain versions of PostgreSQL, called the
use-after-free bug, can cause segmentation faults. If you are affected, you should upgrade. The affected PostgreSQL versions are:
- PostgreSQL 12 versions earlier than 12.7. The bug was patched in PostgreSQL 12.7.
- PostgreSQL 13 versions earlier than 13.3. The bug was patched in PostgreSQL 13.3.
Which versions of GitLab could be affected?
- GitLab EE versions 14.9 and later are affected, if your version of PostgreSQL is an affected version.
- GitLab CE versions 15.1 and later are affected, if your version of PostgreSQL is an affected version.
- Omnibus GitLab instances using a bundled PostgreSQL server are not affected as they ship with patched versions of PostgreSQL, and no further action is needed.
We strongly recommend all instances using an affected PostgreSQL version to upgrade to the latest minor version for PostgreSQL version 12 or 13.
For more detailed information, review our issue on this problem.
“External PostgreSQL 12.7- and 13.3- servers used with GitLab should be upgraded to the latest minor version.” – Yannis Roussos
Click to tweet